0

Impossible reindex magento 2.1.11

In terminal I run:

php bin/magento indexer:reindex

The first 3 indexes reindex in a few seconds. Reindex stops on the 4th index and this is the end. I waited all night and stood still.

Reindex stops at:

Indexed category / product associations

  • I try reset all indexex
  • also I try fix issue with deadlock:

https://www.tigren.com/fix-deadlock-error-reindexing-magento-2/

any other solution?

@update I found one solution:

  • Reset indexes: bin/magento indexer:reset
  • Make sure that no database processes regarding indexing is running
  • Open your database administration client like PHPMyAdmin
  • Run query: SHOW PROCESSLIST;
  • Run query: KILL QUERY xxxxx (where xxxxx is the ID of processes you want to kill)
  • bin/magento setup:upgrade Clear cache
  • bin/magento setup:static-content:deploy -j 1
  • bin/magento indexer:reindex
  • Disable maintenance mode bin/magento maintenance:disable

But can anyone confirm that I need kill this both process?

https://prnt.sc/nvbr2e

  • Have you checked the logs to see if something is going wrong? – SantiBM May 30 '19 at 7:23
  • Unfortunately, there is no information in the logs that could indicate some error. – Sylvester May 30 '19 at 7:39
  • do you see actual indexer php process id running? – MagenX May 30 '19 at 8:45
  • Where can I check it? Can you explain to me more what you mean? – Sylvester May 30 '19 at 8:48
  • type this command in ps aux | grep indexer – MagenX May 30 '19 at 8:50
1

change magento to developer mode

make sure your debug/developer logs enabled. also check php error logs.

you have to check your database for errors:

mysqlcheck MAGENTO_DB --silent

then open second ssh session and read your magento logs:

tail -f var/log/system.log & tail -f var/log/exception.log

open third ssh session and read your strace file:

tail -f indexer_strace 

start your indexer with strace, either as root or magento files user:

strace -s 99999 bin/magento indexer:reindex 1>indexer_strace 2>&1

this will be a little start to your debug.

| improve this answer | |
  • MagenX, before this, can you please check my topic update? – Sylvester May 30 '19 at 9:37
  • the steps you listed is to hide or jump over the issue you have, it will not fix it. – MagenX May 31 '19 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.