2

What is the solution to be able to search Magento 2 catalog with less than three characters.

This is what i have done so far from looking at Magento 1 info regarding this issue.

Setting "Max Query Lengt" in backend to 2
Changed the mysql setting ft_min_word_len=2 and restarted the server. reindex and clear cache.

I have also tried to move the following indexing tables to MyISAM and then run a REPAIR QUICK on them and update the indexes

catalogsearch_fulltext_scope1
cms_block
cms_page
customer_grid_flat
sales_creditmemo_grid
sales_invoice_grid
sales_order_grid
sales_shipment_grid
catalogsearch_fulltext

The tricky thing with this is that bin/magento indexer:reindex changes them back to InnoBD. Don't know if they are dropped and recreated or how that happens but that's my result after a magento reindex.
The enginge change, repair, flushing and so on is done after magento reindex.

If anyone have an idea where to go from here i would be quite happy?

Thanks in advance
Thomas

0

I had also this problem. I resolved it adding

[mysqld]
innodb_ft_min_token_size=1
ft_min_word_len=1

(in your case equal to 2) to /etc/mysql/my.cnf inside the [mysqld] section, restart mysql daemon and then run:

php bin/magento indexer:reindex

inside magento root directory. With the innodb global variable which I wrote earlier the settings value also for the innodb engine.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.