1

I am getting messages from our server that we need to update the installation of MySQL and possibly install Maria. (MySQL 5.6 to 5.7) Problem is that we are on a self hosted VPN and the server company will not do the upgrade on an adhock payment basis and our developer will not touch the server. (he only works on Magento). I can't seem to find any information on whether or not this upgrade will work with Mag 2.2 but I am finding warnings that the Maria install can corrupt databases and that Magento may or may not work with it.

So.....can anyone tell me if Mag 2.2 is better off with or without Maria? As well, are there any developers that are willing to work on a fixed price basis to do the back up and the upgrade?

Thanks

  • have you got the answer of your query? – Muhammad Hasham Mar 26 at 6:20
0

As you are using Magento version 2.2, so technology stack requirements for mySQL and MariaDB are as following

Database

MySQL 5.6, 5.7

Magento is also compatible with MySQL NDB Cluster 7.4.*, MariaDB 10.0, 10.1, 10.2, Percona 5.7, and other binary-compatible MySQL technologies.

Magento only uses MySQL features compatible with MariaDB. MariaDB may not be compatible with all MySQL features, however, so be sure to research compatibility issues before using a feature in your Magento module.

Reference Magento documentation: https://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html

I hope this will help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.