0

i am new to magento enter image description hereusing the below command and got the issue as below

E:\wamp\www\magento226>php bin\magento migrate:setting -r vendor\magento\data-migration-tool\etc\opensourse-to-opensourse\1.9.0.1\config.xml

[Migration\Exception] Invalid config filename: vendor\magento\data-migration-tool\etc\opensourse-to-opensourse\1.9.0.1\config.xml

migrate:settings [-r|--reset] [-a|--auto] [--]

And generally in the tutorials can able see in the etc folder ce-to-ce, ce-to-ee and ee-to-ee, but here in my machine i can see commerce-to-commerce,opensource-to-commerce and opensource-to-opensource

enter image description here

  • did you change the config.xml file name in this locationvendor\magento\data-migration-tool\etc\opensourse-to-opensourse\1.9.0.1` from config.xml.dist` to config.xml ? – Rakesh Varma Nov 1 '18 at 4:52
  • did you try with full path like this? E:\wamp\www\magento226>php bin\magento migrate:setting -r E:\wamp\www\magento226\vendor\magento\data-migration-tool\etc\opensourse-to-opensourse\1.9.0.1\config.xml – Rakesh Varma Nov 1 '18 at 5:27
  • tried with your suggestion ,but result is same – Shiva Gadupudi Nov 1 '18 at 5:33
  • if possible upload screenshot of your directory structure and files in this location `\wamp\www\magento226\vendor\magento\data-migration-tool\etc\opensourse-to-opensourse\1.9.0.1` – Rakesh Varma Nov 1 '18 at 5:34
  • Thanks Rakesh for the quick comment , just added the image for folder structure – Shiva Gadupudi Nov 1 '18 at 6:30
1

there is a mistake in spelling its not opensourse its opensource

try this

E:\wamp\www\magento226>php bin\magento migrate:setting -r vendor\magento\data-migration-tool\etc\opensource-to-opensource\1.9.0.1\config.xml
  • its working now , Thanks for ur reply Rakesh – Shiva Gadupudi Nov 2 '18 at 9:47
  • Welcome. Accept answer if its help you – Rakesh Varma Nov 2 '18 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.