0

Steps.

  1. Edit vendor/magento/data-migration-tool/etc/opensource-to-opensource/1.9.3.1/config.xml for database config at old and new databases.
    <source>
        <database host="localhost" name="old_database" user="old_user" password="PaSswOrD" />
    </source>
    <destination>
        <database host="localhost" name="new_database" user="new_user" password="PaSswOrD" />
    </destination>
    <options>
        <destination_prefix>ovh</destination_prefix>
  1. My Old database has not prefix
  2. New database has prefix ovh_ (I've tried on change in settings file to ovh_ also). Also tried <dest_prefix>ovh_</dest_prefix>

  3. Execute magento migration tool

magento migrate:settings /home/tienda/tienda_develop/magento/vendor/magento/data-migration-tool/etc/opensource-to-opensource/1.9.3.1/config.xml 

Get error:

[2019-11-05 16:27:15][INFO][mode: settings][stage: integrity check][step: Settings Step]: started
100% [============================] Remaining Time: < 1 sec
[2019-11-05 16:27:15][ERROR]: Integrity check failed due to "core_config_data" document does not exist in the destination resource
[NOTICE]: Please check if table names uses prefix, add it to your config.xml file
[2019-11-05 16:27:15][INFO][mode: settings][stage: integrity check][step: Stores Step]: started
100% [============================] Remaining Time: < 1 sec

I work over official manual

1 Answer 1

1

Just had same problem correct settings would have been

<dest_prefix>ovh_</dest_prefix>

make sure options does not still contain the default <dest_prefix /> if it does erase it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.