2

It may be meaningless. I hope there may be some adjustments to use the RWD theme for Magento 1.8.1.

Unfortunately I have to use magento 1.8. I need more extensions to meet all client requirements. Many of these extensions are not supported by Magento 1.9. But I liked the Magento 1.9 Responsive Theme very much.

  • I've yet to work with the rwd theme in 1.9 but I don't think you could simply plug that theme into 1.8 due to dependencies it requires only introduced in 1.9. Perhaps another Magento developer that has worked with the 1,9 rwd theme can confirm... – zigojacko Jun 11 '14 at 12:28
  • Are you sure you have to stick to 1.8? Many extensions made for 1.8 might still be compatible with 1.9 even if that is not explicitly stated. – Alex Jan 21 '15 at 12:36
1

I have the same exact situation going myself, siva. I was curious, so I went ahead and did it. So far so good. The only issues I had was indexing. I took the special prices module, which doesn't exist in 1.8, and that did the trick for now. It is running fairly smoothly.

  • Thanks Brain for your response.can you share your experience.I mean how you done? – sivakumar Jul 14 '14 at 17:54
  • Themes should work in any magento version provided the features it uses from the specific version is also ported. i.e if your 1.9 theme uses ay special feature from the catalog module which is not in 1.8 then you have to make the necessary changes in 1.8 to get the theme working. – Tarun Dec 22 '14 at 6:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.