0

I've change the website and store view to a new theme at content->Design Configuration. But when i visit frontend, all the static files are keeping at http://domain.com/pub/static/version1530690579/frontend/Oldvendorname/oldthemename/en_US/css/styles-l.css,

it should be http://domain.com/pub/static/version1530690579/frontend/Newvendorname/newthemename/en_US/css/styles-l.css

3
  • Did you clear Magento cache and Browser cache? – Khoa TruongDinh Jul 4 '18 at 8:00
  • already clean all the cache – hkguile Jul 4 '18 at 8:04
  • @hkguile same problem with me. Did you get any solution? – Mandar Parbate Apr 2 '20 at 5:40
0

How did you change the theme? I think you have mistakenly changed the theme globally or for website level.

There is an option to change the theme at store view level also. I think your old theme is set on the store view level, so it is taking priority.

To verify, go to Content > Design (Configuration) and check that you have applied the new theme at the store view level.

Store View Theme Settings

If above is not the case, then remove content from pub/static/frontend and var/cache, var/page_cache folder and reload the website.

1
  • all tried, seems not related – hkguile Jul 4 '18 at 9:49
0

You can regenerate the static files by running this command in ssh:

php bin/magento setup:static-content:deploy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.