0

I am getting following error on Magento 2.2 after upgrading from 2.1.9

1 exception(s):
Exception #0 (InvalidArgumentException): Unable to unserialise value.

The string on which this error is occurring is as below

a:6:{s:4:"type";s:44:"Amasty\Xlanding\Model\Rule\Condition\Combine";s:9:"attribute";N;s:8:"operator";N;s:5:"value";s:1:"1";s:18:"is_value_processed";N;s:10:"aggregator";s:3:"all";}

Any help will be appreciated!

1
  • 1
    Contact Amasty support and update the Amasty\Xlanding module – Siarhey Uchukhlebau Oct 9 '17 at 8:09
0

Looks like the extension Amasty_Xlanding is not compatible some how with Magento 2.1.9.

Disable the extension and ask Amasty guys for the latest version of this extension.

You can disable any extension following the steps described in here.

You can also use the command line tool:

php bin/magento module:disable Amasty_Xlanding

1
  • Hi, Thanks for getting back. I did disabled it and it worked. However, the module provider has said that their module is compatible with 2.2. Does this string has an error it "a:6: s:4:"type";s:44:"Amasty\Xlanding\Model\Rule\Condition\Combine";s:9:"attribute";N;s:8:"operator";N;s:5:"value";s:1:"1";s:18:"is_value_processed";N;s:10:"aggregator";s:3:"all";} " , So that I correct it at my end – Tech Dog Oct 8 '17 at 8:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.