0

What is wrong?

Recently I tried out an extension on my test environment of magento 1.9.2 It was a succesful installation with magento connect.

The extension worked perfectly.

so I tried it out on my real environment but the extension / module doesn't work and won't show up in my modules tab ( system - configuration - advanced ). so I can't enable or disable it.

the files have been places in the right folder ( app - code - community ) So far I tried

reinstalling the extension logging in and out flushing the cache re-indexing the website But sadly it did not seem to work on my real environment.

What extension?

this is about the "Catalog Search Refinement FREE" extension.

The extension has no panel since all this extension does is change the way magento searches for products.

I am new to magento, so I might not know much and I've read a lot but I can't find what I'm doing wrong.

closed as off-topic by sv3n, Manoj Deswal, Amit Bera, liyakat, Jai Oct 19 '17 at 16:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced OR seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – sv3n, Manoj Deswal, Amit Bera, liyakat, Jai
If this question can be reworded to fit the rules in the help center, please edit the question.

  • check files permissions of the uploaded extension, make sure you uploaded files not only into app/code/community, but also in app/etc/modules – Pavel Novitsky Oct 3 '17 at 8:52
  • If Compiler Status is Enabled, Go to System > Tools > Compilation and click on Run Compilation Process. – Baby in Magento Oct 3 '17 at 9:05
  • I have yet to learn about permissions, could you explain me how to check and change the permissions? I looked into the folder you told and the XML file was indeed in there, the codepool was correct and it was set as active as it should. – Jeffrey Ullers Oct 3 '17 at 9:10
  • thanks! @babyInMagento , okay but I'm still stuck with my case, even after running the compilation process it didn't fix my problem. – Jeffrey Ullers Oct 3 '17 at 9:19
  • @babyinMagento Exactly, it is only showing that it's installed in magento connect but not in the modules tab – Jeffrey Ullers Oct 3 '17 at 9:27
0

So okay I found out Magento wasn't deleting my cache properly, after hours and hours of searching for errors, editing lines of code it was simply running on my cache all the time. Even after flushing the cache and reindexing my website countless times I wondered if my cache was being deleted correctly. Since I kept getting the same advice from other people to flush my cache I wondered if it was being flushed correctly. so I went to var/cache and saw that even after flushing my cache these files remained.

So I deleted all the folders in var/cache and logged out and in on my Magento back-end and I noticed directly that the extension was working as it should.

Not the answer you're looking for? Browse other questions tagged or ask your own question.