0

I am uploading a large number products. The upload runs perfectly but Magento is not adding the file extension to the url_key. So none of the products uploaded have the “.htm” file extension. Even after indexing. I’ve tried everything I can think of to resolve this. I’m using version 1.9.4. This is driving me crazy. I've tried running the import without passing the url_key and the url_path. Magento creates the url with the product name and still no ".htm" extension as configured in the SEO settings.

0

To make product URL with some particular extension, you need to indicate necessary URL suffix in Magento admin settings. Open System-> Configuration -> Catalog-> Search Engine Optimization and specify .htm in 'Category URL Suffix' field.

Flush Magento cache and perform re-index procedure.

| improve this answer | |
  • So finding clear and detailed instructions on how to import into magento has been very challenging. I finally understand that even though the url_key field does not show the .htm extension, magento does in fact present the page with extension through the rewrite. Thank you Lillian. This was a lot of work to figure this out since there was nothing I could find that explicitly described how the url_key field is rewritten. – MicNet Mar 21 '17 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.