0

I discovered that Magento - when calling the addJs php function and when using the layout.xml file - merges all the javascript tag in one single tag, producing something like

<script src="domain.com/js/scriptA.js,/js/scriptB.js,/js/scriptC.js"> etc...

How can I disable this (awful) feature?

1

Log in to your admin and go to System --> Configuration. Select Developer from the left sidebar and disable JavaScript merging.

| improve this answer | |
  • tried it, but it still combines js calls in one tag... – sekmo Apr 29 '17 at 8:52
  • Did you clear your cache after changing that setting? – Brett Apr 29 '17 at 12:46
0

The solution is disabling js merging on system>configuration>developer, or (in my case) disable extensions like "fooman speedster". Banged my head for a solid afternoon.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.