1

with a fresh install of Magento 2.1.6, I'm trying to install any compatible extension, and I always get this message below:

Check Component Dependency We found conflicting component dependencies. Hide detail

For additional assistance, see component dependency help.

with no further explanation letting me know what's the problem

everything else seems to be working fine "Cron jobs", I tried everything on the web

  • expanded my memory.

  • managed users.

2

You may see "require-dev" tag in composer.json file.

Run composer install or update with --no-dev flag. This will not install developer dependency packages.

composer install --no-dev

OR

composer update --no-dev
3

Removing the following from composer.json worked for me also to get past this issue.

},
"require-dev": {
    "phpunit/phpunit": "4.1.0",
    "squizlabs/php_codesniffer": "1.5.3",
    "phpmd/phpmd": "@stable",
    "pdepend/pdepend": "2.4.0",
    "fabpot/php-cs-fixer": "~1.2",
    "lusitanian/oauth": "~0.3 <=0.7.0",
    "sebastian/phpcpd": "2.0.0"
},

Would be really interesting to know why removing this worked?

0

It happened with me, open this file on your module:

app/code/NEWMODULE/NAME/etc/module.xml

Then check the dependencies, and check if you have all dependencies modules installed and enable.

You can check the modules enabled using this command:

php -f bin/magento module:status
  • 1
    i solved it already by removing the Require dev tag from the composer.json actually Thanks :) – joe Apr 18 '17 at 1:26
0

After two days trying different things, also worked for me the following:

Removing the following from composer.json worked for me also to get past this issue.

}, "require-dev": { "phpunit/phpunit": "4.1.0", "squizlabs/php_codesniffer": "1.5.3", "phpmd/phpmd": "@stable", "pdepend/pdepend": "2.4.0", "fabpot/php-cs-fixer": "~1.2", "lusitanian/oauth": "~0.3 <=0.7.0", "sebastian/phpcpd": "2.0.0" },

Thanks

0

Yes removing below lines from composer.json worked for me as well

    },
"require-dev": {
    "phpunit/phpunit": "4.1.0",
    "squizlabs/php_codesniffer": "1.5.3",
    "phpmd/phpmd": "@stable",
    "pdepend/pdepend": "2.4.0",
    "fabpot/php-cs-fixer": "~1.2",
    "lusitanian/oauth": "~0.3 <=0.7.0",
    "sebastian/phpcpd": "2.0.0"
},

Thank you for the solution !!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.