0

Magento:

I am trying to update the magento via Web setup and its giving me error

Check Component Dependency We found conflicting component dependencies. Hide detail

Command "update" failed: Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1

The requested package magento/product-comunity-edition could not be found in any version, there may be a typo in the package name. Potential causes:

A typo in the package name The package is not available in a stable-enough version according to your minimum-stability setting see https://getcomposer.org/doc/04-schema.md#minimum-stability for more details. Read https://getcomposer.org/doc/articles/troubleshooting.md for further common problems.

For additional assistance, see component dependency help .

Then i tried the CLI methods too, but this is the error i am getting [root@eme ~]$ composer update Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1 - Installation request for magento/product-community-edition 2.1.0 -> satisfiable by magento/product-community-edition[2.1.0]. - magento/product-community-edition 2.1.0 requires composer/composer 1.0.0-beta1 -> satisfiable by composer/composer[1.0.0-beta1] but these conflict with your requirements or minimum-stability.

My Composer.json

{
"name": "magento/project-community-edition",
"description": "eCommerce Platform for Growth (Community Edition)",
"type": "project",
"version": "2.1.3",
"license": [
    "OSL-3.0",
    "AFL-3.0"
],
"require": {
    "magento/product-community-edition": "2.1.4",
    "composer/composer": "@alpha",
    "magento/product-comunity-edition": "2.1.4"
},
"require-dev": {
    "phpunit/phpunit": "4.1.0",
    "squizlabs/php_codesniffer": "1.5.3",
    "phpmd/phpmd": "@stable",
    "pdepend/pdepend": "2.2.2",
    "fabpot/php-cs-fixer": "~1.2",
    "lusitanian/oauth": "~0.3 <=0.7.0",
    "sebastian/phpcpd": "2.0.0"
},
"config": {
    "use-include-path": true
},
"autoload": {
    "psr-4": {
        "Magento\\Framework\\": "lib/internal/Magento/Framework/",
        "Magento\\Setup\\": "setup/src/Magento/Setup/",
        "Magento\\": "app/code/Magento/"
    },
    "psr-0": {
        "": "app/code/"
    },
    "files": [
        "app/etc/NonComposerComponentRegistration.php"
    ]
},
"autoload-dev": {
    "psr-4": {
        "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
        "Magento\\Tools\\": "dev/tools/Magento/Tools/",
        "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
        "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
        "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
    }
},
"minimum-stability": "alpha",
"prefer-stable": true,
"repositories": [
    {
        "type": "composer",
        "url": "https://repo.magento.com/"
    }
],
"extra": {
    "magento-force": "override"
}
}
  • Can you please update your question with your composer.json file? – Danny Nimmo Feb 19 '17 at 10:18
  • added composer.json – Stanly Stephen Feb 19 '17 at 10:47
1

You need to remove the "magento/product-comunity-edition": "2.1.4" line from your composer.json (note the typo in the word "community").

Make sure you also remove the trailing comma , from the previous line to maintain valid JSON syntax.

Your final require block should end up like the following:

"require": {
    "magento/product-community-edition": "2.1.4",
    "composer/composer": "@alpha"
},

Once this is fixed up, you should be able to run composer update to install v2.1.4

  • hi danny, this composer has been created by magento, any way i am using this solution to check if this solve our program – Stanly Stephen Feb 19 '17 at 11:10
  • Thanks bro the typo was the mistake. I had fixed it via editing the same via nano editor – Stanly Stephen Feb 19 '17 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.