2

We have setup all our tax classes and tax settings in Magento 2 and everything is working perfect, only in the shopping cart the tax is not calculated in the grand total. In the rest of the checkout proces and in orders it does show up. We have setup "display prices" to yes and I included down here a printscreen with the settings:

enter image description here

Does anyone have an idea why the tax is not showing up in the cart?

1
  • 2
    Is there a solution for this yet? I have the same problem. I already have my Shipping Origin (Stores > Configuration > Sales > Shipping Settings > Origin) set. Have you tried this Coen? Feb 22, 2017 at 11:37

3 Answers 3

4

I had this problem as well. Somehow my products were all set to Tax Class: none. I had configured taxes correctly, but in the shopping cart it was still showing zero taxes.

The issue was solved by accessing the product details: Catalog > Products > View Product

Change tax class to "Taxable Goods" or whatever your tax class name is.

enter image description here

2
  • There is no such field called "Tax Class"
    – Black
    Dec 3, 2020 at 9:01
  • I am facing similar issue, I have the taxable goods selected also my settings are correct from: Shopping Cart Display Settings . Any idea what else should I try ? Jan 19, 2021 at 13:22
3

Change the settings Stores -> Configuration -> Sales -> Shipping Settings -> Origin

Expand this tab and change the country to your country.

1
  • Worked for me , thanks ! Feb 17, 2022 at 9:17
0

I was having same issue then I noticed that I have not selected countries under Store->Configuration->Sales->Tax->Integration Setting->Allowed Countries

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.