2

The VAT Tax breakdown isn't being shown on the shopping basket when a visitor adds a product to it. If they go to checkout, and then back (without doing anything in checkout), it will display the breakdown. Otherwise it just displays a sub total and total (which are exactly the same).

The settings we have configured are:

  • Tax calculation method based on: Unit Price
  • Tax Calculation Based On: Shipping Address
  • Catalog Prices: Excluding Tax
  • Delivery Prices: Excluding Tax
  • Apply Customer Tax: After Discount
  • Apply Discount On Prices: Excluding Tax
  • Default Country: UK
  • Default State/Post Code: *

Shopping Cart Display Settings

  • Prices: Excluding Tax
  • Sub Total: Excluding Tax
  • Delivery Amount: Incl. and Excl. Tax
  • Include Tax in Grand Total: No (Even on yes, this just shows two prices exactly the same, without VAT being added on).

There are several Tax rates set up, one for each applicable country at 20%. The Tax Rule is applied to retail customers and taxable goods; the issue seems to happen when multiple tax rates are selected (if I just select the UK VAT one, prices display as expected, otherwise if I select them all, it only displays ex VAT in everything).

Any ideas? I've followed both magento guides/documentation and other blog posts on doing this, and none of them help resolve the issue unfortunately.

1

This is most likely due to the Tax Origin not being set correctly (it's probably on its default: US). This is different from the Default Country setting, you can find it at System -> Configuration -> [SALES] Tax -> Origin.

Let me know if it works! :)

  • There isn't a "Origin" option, but there is a "Default Tax Destination Calculation - Default Country" which is set to UK. So no luck I'm afraid. – David Dec 17 '14 at 15:05
  • Argh, excuse me, I translated it from Dutch, thinking it was a different option. Sorry! – Marco de Vries Dec 17 '14 at 16:31
0

When importing the tax rate from a CSV there was a missing column of default which can have a 1 inside it to represent which tax rate is the default tax rate.

I was using the CSV from http://www.mcnab.co/blog/e-commerce/magento/magento-vat-setup-for-countries-trading-worldwide/ which was missing several columns compared to the Magento export version. So I had to re-import the tax rates to fix the issue.

The columns missed (following the Rate column) were Zip/Post is Range, Range From, Range To and default which can all be left blank (except I placed a 1 in the default tax rate I wanted to use, e.g. UK VAT)

Hope that helps anyone else that encounters this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.