2

I've setup a Magento 2.1.2 and things seem to be working fine (categories, attribute sets, etc.).

The first test product though I created a simple product from the default attribute set an had:

  • Enable Product: Yes
  • Quantity: 100
  • Stock status: In Stock
  • Categories: MyTest
  • Visibility: Catalog,Search
  • Websites: Main Website

After saving it, it doesn't show in my category. Then I ran the cronjob, the indexes got updated and nothing shows up. Then I flushed the cashes, still nothing on the frontend. I search for the SKU, nothing shows up as well. I'm wondering whether I'm missing something?

  • Are you on the good website / database ? are you sure of every steps you've described ? It seems you do good. it should have been displayed. – Pierre FAY Nov 21 '16 at 15:55
  • After diging around, it seems as if the cron jobs don't trigger the re-index process if needed and my admin panel didn't tell me to re-index. So I explicitly called: php bin/magento indexer:reindex and now it's working. So I just assumed I ran the index with the crons but actually didn't - sorry for the trouble caused. – Chris Nov 22 '16 at 0:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.