5

After upgrading my local instance of magento 2.1 to 2.1.2 the bin/magento tools stopped working. I do not get an error or any output. For instance when I run php bin/magento setup:upgrade after upgrade it seems like it is doing something, but get no output and does not seem to have done the upgrade on modules. Anyone else seen this issue?

  • Does simple call to bin/magento returns anything? – Sergii Ivashchenko Feb 3 '17 at 17:53
2

You should actually check error_log file on magento root which will give out errors for cli runtime errors. Also try using -vvv flag to set verbose level.

It was memory shortfall for me.

1

You should check the permissions for the bin/magento folder to make sure that after the upgrade (especially if you did the upgrade as a different user then the site user) you still have the right ownership.

After that, clear the var folder's cache generation page_cache and view_preprocessed folders as these can cause all kinds of havoc if not cleared.

Other then that, spell out more clearly what it is that happens when the site hangs.

1

Just as an FYI, I thought setup:upgrade had frozen on me because there was no output but it eventually finished after a good 15 minutes. Might be worth leaving it for an hour or checking disk activity if you think it's frozen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.