I tried installing cpanel on my VPS (which already had a Magento 2.4.4 instance working on it) using this guide: https://www.cloudbooklet.com/how-to-install-cpanel-whm-on-ubuntu-20-04/

The cpanel did not work, however, I also noticed that I couldnt access the Magento website. It is giving me this error: enter image description here

And when I run php bin/magento setup:upgrade I get this error: enter image description here

Can anyone help me fix this?

  • Have you configured the database correctly in app/etc/env.php file? That is hostname, port, database name, username, etc... if yes then please cross check if database exist Commented Nov 11, 2022 at 14:04

1 Answer 1


I don't know if this will help you.

  1. Check the apache or ngnix installed.
  2. Check MySQL and PHP installed and check PHP modules.
  3. Check the vhost settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.