2

I upgrade my store to last Magento version 1.9.2.4 and I add ssl, When I try save a new product or edit an existing product in Magento everything is saved correctly except upsell/related/cross sell products. Product is being saved with no errors. In var/log/ I don't have any errors. If I hit edit again the upsell product I selected before wasn't saved.

Update:

I try to turn off the https and now upsell/related/cross sell products can be selected from admin product page, what I can do to solve this, to work with https?

My server is on nginx and to work my store with https I add this in index.php

foreach (array(
    'SERVER_PORT' => 443,
    'HTTP_X_FORWARDED_PROTO' => 'https',
    'HTTP_CF_VISITOR' => '{"scheme":"https"}'
) as $key => $values) {
    if (isset($_SERVER[$key]) && $_SERVER[$key] == $values) {
        $_SERVER['HTTPS'] = 'on';
        break;
    }
}
3

I am guessing that you are using Google Chrome so you might want to try firefox. The upsell, cross sell, and related products tabs are loaded via ajax and due to the way different browsers handle javascript, it doesn't always submit ajax loaded content with the rest of your form.

For example, click on the Upsells tab, dont change anything, and then click save. After you have clicked save, make changes to the upsell tab and click save again. It should then save your changes. I know that's a pain to do but I have also had this issue in the past and this worked for me.

| improve this answer | |
  • Hi thank you but I use firefox is the same thing – Robert Aug 20 '16 at 21:02
  • Ok regardless of the browser, try what I mention in the second paragraph. It's not ideal but it should work – Shawn Abramson Aug 20 '16 at 21:03
  • I do this right now, I check all related products and I press save, No records found. – Robert Aug 20 '16 at 21:04
  • I think this is something related to the ssl or maybe to nginx, I don;t know, for that I post here, maybe someone can help me to solve this, I have the same thing with reset forgot password, after I click on reset button in email I have: Your password reset link has expired. – Robert Aug 20 '16 at 21:07
  • It's prob not related to nginx. Possibly your SSL but the only reason I doubt it is that I assume the rest of your form works. Content that gets loaded via Ajax is not part of the Dom and as a result it doesn't get submitted. This is actually a common problem. Have you tried other browsers to see if you get different results? Something that doesn't work in one browser may work in another. I had this same headache as you for a while, but no more. – Shawn Abramson Aug 20 '16 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.