0

I have a dev site on magento 1.9.4.2 . Now I am trying to redirect my web site to my domain (the server is the same)

I have changed the

  1. web/unsecure/base_url
  2. web/secure/base_url
  3. and web/url/redirect_to_base to 0.

I have also cleared

  1. var/cache
  2. and var/session.
  3. system/tmp/magento/cache

But I am still getting a redirect loop issue.

can someone help me?

0

Can you provide us with your .htaccess file in your Magento directory? This could be because your .htaccess redirects all your urls to http://www.yourdomain.com but your Magento installation is trying to redirect to www.yourdomain.com or yourdomain.com (yes, there's a difference). You can check this by adding / removing http://www. and www. from your web/unsecure/base_url and web/secure/base_url.

  • on the default .htaccess i found that www.yourdomain.com and i switched to my new an still nothing...for a test i deleted my .htaccess and still nothing...dont know what to do more – Ricardo Costa Aug 2 '16 at 18:14
  • and in my web/unsecure/base_url i have tryied with www.domain.com/ and www.domain.com – Ricardo Costa Aug 2 '16 at 18:16
  • after changing back to my .htaccess i changed all www.yourdomain.com to my domain and 2 things happen..when i go with my domain my page enter in a infinite loop beteewn domain and the ip/path, and when i try to access with ip/path it redirects to www.yourdomain.com, but i checked and my .htaccess does not have more references to it – Ricardo Costa Aug 2 '16 at 18:29
  • If you try to save the following code as cleancache.php in your Magento directory: link and then delete/rename your .htaccess. Then run www.yourdomain.com/cleancache.php what do you see? Also make sure that you set the same url yourdomain.com for every store(view) and not just the default in Magento. – Ruud N. Aug 2 '16 at 18:58
  • Start Cleaning all caches at ... 2016-08-02 19:53:38 Cleaning data cache... Removing config ... [OK] Removing layout ... [OK] Removing block_html ... [OK] Removing translate ... [OK] Removing collections ... [OK] Removing eav ... [OK] Removing config_api ... [OK] Removing config_api2 ... [OK] Cleaning stored cache... [OK] Cleaning merged JS/CSS...[OK] Cleaning image cache... [OK] – Ricardo Costa Aug 2 '16 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.