0

After I did an upgrade to latest magento CE version 1.9.2.4, I noticed 2 weird changes:

frontend: home page url was changed to /STORECODE/cms/index/index

backend: once an admin user logged in, he will face 404 error, the url is admin/index/noRoute

I've no conflicts. All modules have been updated to the new routing. Other admin functions are working and frontend pages are working as expected too.

this redirection is happening on php level

10
  • what was your prior version? and how did you update? via supee or reinstall?
    – Michael
    Jul 3, 2016 at 6:55
  • older version was 1.9.0.1 and I updated via full reinstall then I patched the local/community modules
    – tawfekov
    Jul 3, 2016 at 7:31
  • then there may be store view code in url be active in the backend. if you disable this option again, all should be fine. if it is disabled already, enable it, save, disable it and save again.
    – Michael
    Jul 3, 2016 at 8:01
  • What do you mean with a full install? Did you import your database? This is a setting in the database, so in case you reset your database it is possible that "include store code in URL" can be on now.
    – Alex
    Jul 3, 2016 at 8:02
  • @Michael , I tried to disable it and reenabled it but with no luck
    – tawfekov
    Jul 3, 2016 at 10:11

1 Answer 1

1

turned out the issue is caused by manadev layered navigation seo module , it has a custom router

app/code/local/Mana/Seo/Router.php

the lines 110 - 113 was creating the redirect based on of options was : Redirect To Same Page With Correct Parameter Order and the docs recommend to set it to yes , setting it to no solved the issues on frontend & backend

seems to be a bug related to this module , I've reported it back to them ,

its not related to magento upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.