0

I have a request for the installation php7 for Apache

sudo apt-get install -y php7.0 libapache2-mod-php7.0 php7.0 php7.0-common php7.0-gd php7.0-mysql php7.0-mcrypt php7.0-curl php7.0-intl php7.0-xsl php7.0-mbstring php7.0-zip php7.0-bcmath php7.0-iconv

What a complete request must be for Nginx?

4
  • this package is the most important php7.0-fpm
    – MagenX
    Jun 17 '16 at 12:07
  • I think most delete libapache2-mod-php7.0 And request will this: sudo apt-get install -y php7.0-fpm php7.0-common php7.0-gd php7.0-mysql php7.0-mcrypt php7.0-curl php7.0-intl php7.0-xsl php7.0-mbstring php7.0-zip php7.0-bcmath php7.0-iconv
    – Sylon
    Jun 17 '16 at 12:43
  • Guys, please, give me correct full command.
    – Sylon
    Jun 18 '16 at 6:54
  • run magento readiness check, it will show you whats missing...
    – MagenX
    Jun 18 '16 at 8:49
1

Just replace libapache2-mod-php7.0 with php7.0-fpm.

like

sudo apt-get install -y php7.0 with php7.0-fpm php7.0 php7.0-common php7.0-gd php7.0-mysql php7.0-mcrypt php7.0-curl php7.0-intl php7.0-xsl php7.0-mbstring php7.0-zip php7.0-bcmath php7.0-iconv 

Looks like better to add php7.0-opcache php7.0-soap php7.0-json php7.0-xml to list of modules

1
  • Right? sudo apt-get install -y php7.0-fpm libapache2-mod-php7.0 php7.0-common php7.0-gd php7.0-mysql php7.0-mcrypt php7.0-curl php7.0-intl php7.0-xsl php7.0-mbstring php7.0-zip php7.0-bcmath php7.0-iconv
    – Sylon
    Jun 16 '16 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.