1

I have installed a new Magento install on my local machine and have given it a new theme. I updated the theme in the Config section in the admin, but the CSS for the theme is not being loaded. Instead, the css files in skin/frontend/base are being loaded. How can I change the folder from base to ?

The path to my theme is skin/frontend/. The only thing I have changed in the admin has been at System -> Conficuration -> Design and under the Package dropdown, I changed default to

  • Could you provide more details plz? The path to the theme (skin) and what you changed in system config. – Toon Van Dooren Dec 3 '13 at 21:41
  • @ToonVanDooren done. See above – jordan Dec 3 '13 at 21:49
  • Is the folder after the package name named default? + did you try to clear cache? – Toon Van Dooren Dec 3 '13 at 21:50
3

You seem to be talking about two different things. In Magento, there are

a) packages
b) themes

The package defines the first folder and the theme the underlying "child" folder. An example:

app/design/frontend/PACKAGE/THEME

Furthermore, you can specify a separate folder for your skin via the backend settings, but it will be in the same package that you configured.

So, say you put package = mycompany and theme = mytheme and skin = myskin,

then your paths will be:

app/design/frontend/mycompany/mytheme/template -> for phtml files
app/design/frontend/mycompany/mytheme/layout   -> for layout xml files, e.g. local.xml
skin/frontend/mycompany/myskin                 -> for skin files like css, js, images
  • I got confused between packages and themes. Had the package created but didn't copy the skin directory for my new them – AdRock Apr 2 '14 at 13:06
  • In this example, how woud you set the theme settings? In System > Configuration > Design, only the "Current Package Name" from 'default' to 'mycompany'? – Tim Wachter May 12 '14 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.