1

I have installed magento 2 and previously working on default Luma theme. Now I am trying to install new free theme in my magento. But when I am using below command:

php bin/magento setup:upgrade –keep-generated

It shows an error:

RuntimeException Too many arguments.

Theme is visible under: Content > Theme & Content > Configuration section in admin panel. But my theme Design section is not visible under Stores > Configuration > General > Design section.

Please help me out. I am new to magento 2 and trying to learning about magento 2

0

Remove –keep-generated from your command,

You have to just run command,

php bin/magento setup:upgrade

After Upgrade command, Run deployment command,

php bin/magento setup:static-content:deploy

Remove var folder and check.

1

Read the fact about --keep-generated with setup:upgrade.

The optional --keep-generated option should be used only in limited circumstances by experienced system integrators. --keep-generated should never be used in a development environment.

Improper use of this optional parameter can cause errors during code execution.

–keep-generated command is worked on only on production mode or default mode.

So check your mode of Environment by run this command - php bin/magento deploy:mode:show

Change your mode of environmentby run this command - php bin/magento deploy:mode:set

You can solve your issue by using setp:upgrade command only.

Remove your var/generation directory and run php bin/magento setup:static-content:deploy command.

For more reference refer this link - http://devdocs.magento.com/guides/v2.0/install-gde/install/cli/install-cli-uninstall.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.