1

I am running 1.9.2.2 and when I set a catalog price rule I get nothing in the front end.

I flush the caches, I manually delete /var/cache/* and I've tried reindexing the product prices... Still nothing. In the DB I can see the catalog price rule in the mgwp_catalogrule table but there isn't anything in the mgwp_catalogrule_affected_product table...

Do I need to run a cron job that i don't know about or something...?

Any help appreciated - this is killing me ;(

  • 1. Is the rule active? 2. Is the rule active on this day? 3. Does the rule you created actually include the targeted products? 4. Are there any rule-adjusted prices in the price index? 5. Rule product price table Source: divisionlab.com/solvingmagento/… – versedi Feb 7 '16 at 10:09
  • If this has solved your issue don't hesitate to answer your own question and mark it as accepted. – versedi Feb 8 '16 at 5:28
1

The answer to this riddle was that the new hosting provider we were using has its servers in Central Standard Time and our site was running in NEw Zealand Time. The script that generates the prices in the catalog_product_price table must be dependant on the server time directly because in the morning the system was querying for prices on the 8th and the script had only generated the prices in the catalog_product_price table for the 7th because it was not yet the 8th in CST. hence all prices were reverted to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.