1

We cannot seem to get price rules to apply to products without saving the product. I have tried various methods of resetting, reindexing, truncating tables, checking and manually running cron, but for some reason although products have some rules applied, they don't get all of the rules until the product is saved again.

I have tried adding a new attribute and then mass-updating all of the products to change the attribute, and while I see the indexers update to show them processing an equivalent number of items in their backlogs, the price never updates - it must be saved individually from the product's CMS edit page.

Looking in the catalogrule_product and catalogrule_product_price tables I can see the rules and calculated prices being applied after saving the product.

In my investigation I found that I needed to raise certain innodb settings such as the buffer pool and data file sizes, as we appeared to be getting warnings about the pool size being too small and temp tables being full, but now those warnings appear to have ceased.

Magento 2.2.5, PHP 7.1.32

New contributor
SEPTiMUS is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Hello, your magento version is like ~2years old. There is a huge chance that you issue may be fixed in a newest release. Moreover you may be spending a lot of time fixing a bug when there is a possibility that it is fixed in a next release. :) Please do yo skip updates, this is one of the biggest issue for small/medium projects, they think they don't need updates, but when someone breaks in - then they blame developers. This is just a friendly advice. – Macas 22 hours ago
0

This turned out to be user error with incorrectly specified conditions on catalog price rules.

| improve this answer | |
New contributor
SEPTiMUS is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

SEPTiMUS is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.