2

On live server the cart is working correctly. I change the quantity of a product in the cart then I push the "Update cart" button and all works fine. I transferred the site another domain and the cart quantity doesn't work anymore. As I change the quantity of a product and click the button the quantity remains the same. If I go back and try to add the same product to the cart, even if I specify a different quantity like 10 and not 1, in the cart only 1 item is added every time I click on "add to the cart" button and not 10 as specified. I cannot figure out where's the problem. I excluded my custom theme and rolled back to the default theme and the problem persist. this site other functionality work fine.

  • do you have any javascript errors? – Robin Nov 30 '15 at 9:40
  • no javascript errors show – Imran Hossain Nov 30 '15 at 9:41
1

The below things you could do to make it work:

  1. Clear all caches from System->Cache Management & try in Private window.

  2. If you are using any third party module for related with cart update Add to cart etc. Disable that.

  3. Check your log files in the directory var/log & see if any known error is there.

  4. At last go to your cart controller & check the add & update action in there.

  • I will check 1-3 step but same problem. Please explain step 4 – Imran Hossain Dec 1 '15 at 3:45
  • As the issue is quantity doesn't update so it's action defined in app/code/core/Mage/Checkout/controllers/CartController.php You just debug the addAction & updatePostAction inside that as quantity come to the controller or not etc. Remember just debug & not change the core code. – Akhil Gupta Dec 1 '15 at 5:15
1

In your Theme

/app/design/frontend/yourthemepackage/default/template/checkout/cart.phtml file

Or

/app/design/frontend/default/yourtheme/template/checkout/cart.phtml file

place on line after getUrl('checkout/cart/updatePost') ?>" method="post"> paste the below code

<?php echo $this->getBlockHtml('formkey'); ?>
0
  1. First clear the entire cache.
  2. Login to admin panel
  3. check the number of allowed items in cart option in admin.

At

adminpanel-->system-->configuration-->catalog-->Inventory-->Product Stock Options-->Maximum Qty Allowed in Shopping Cart.

I hope it will help to you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.