0

I'm using Solr with Enterprise Edition 1.13. When running a re-index on catalogsearch_fulltext from the command line about 15 minutes into the process the search on the site will start returning an error page with a MySQL error (1205: Lock wait timeout exceeded). Not long after that the indexer.php script dies. Has anyone else run into this problem? Seems like a bug in the core to me. We have not made any modifications associated with search. Running a re-index when using MySQL Fulltext for search works fine.

  • 1
    Most likely you need to optimize MySQL or the Hardware its running on. Mytop is a great utility to monitor what MySQL is doing, also consider this Question on SO: stackoverflow.com/questions/6000336/… – B00MER Aug 20 '13 at 20:10
  • @B00MER agreed - the box is likely underpowered or improperly configured. Check your innodb size. As a short-term stopgap you could increase your lock wait time. – philwinkle Aug 20 '13 at 21:34
  • We opened a ticket with Magento support and they gave the host a bunch MySQL configuration changes that resolved the problem. The key change was likely setting max_execution_time to 18000. – DSG Sep 9 '13 at 20:42
1

We had a very similar issue although we're running EE 1.12.0.2. We were getting that same lock wait timeout error from front end searches about 15 minutes in to the Solr reindexing process. Ours eventually did finish though, and after that search would work normally again. In our case Magento support provided a patch which fixed this issue. That patch name was PATCH_SUPEE-817_EE_1.12.0.2. I'd suggest opening a Magento support ticket. Hopefully your issue is the same and they'll have a have patch for EE 1.13 as well.

1

You can modify your my.cnf file to increase the wait time out

wait_timeout=1800

Your wait timeout maybe set low

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.