0

I have checked compilation is disabled, cache is clear, re-indexed, turned on development mode (I get no errors). Disabled MageWorx SEO, set the theme/package to default.

The site will load for example, the account login/register page/ the home page, and a few other pages. However, the site will not load categories/products.

Guessing this is a rewrite issue? Any ideas why this would happen after an upgrade?

  • how about to check your php/apache error log?? – user2857 Apr 14 '15 at 20:19
  • I don't have the necessary access to do so, but the host said that they didn't find anything in there... – Matthew Clayton Apr 14 '15 at 21:00
  • what about search with/ with no results pages? check does your config meet the requirements (as you have no access to hosting - maybe you use shared hosting. Check memory_limit in phpinfo and other params too) – zhartaunik Apr 14 '15 at 21:21
  • Sorry, I do have access to the hosting environment but it's not full root access or privileged enough to see the logs myself. That said @zhartaunik I'm not sure I understand your suggestion – Matthew Clayton Apr 14 '15 at 21:22
  • what version of php is running on the server? Is php in safe mode? Internal server error must write an error somewhere, usually into the php error log. Ask your hosting provider if that error log is in fact enabled. Can you get a copy of it to look yourself. This is a php/server issue. Some command/function is causing PHP to hard fail. It could be a required php module is not insyalled, a command that is not supported in current php version, a typo in code.... (as just three possible reasons). – ProxiBlue Apr 14 '15 at 22:17
0

When you have restricted access to your hosting environment and can't debug the problem properly you can enable developer mode in Magento and also enable error display to give you more indications on what could possibly go wrong.

To do that, open your index.php file and make the following changes:

if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) {
    Mage::setIsDeveloperMode(true);
}

change to

if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE']) || true) {
    Mage::setIsDeveloperMode(true);
}

and

#ini_set('display_errors', 1);

change to

ini_set('display_errors', 1);

This will show you exactly what and where is failing without having to ask your hosting provider for help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.