0

I'm working on an e-commerce that have many thousands of products, something like 80,000 products.

The problem is that when I go to Products page, it keeps loading and then crashes or return a 504 gateway error. I have tried to increase the timeout to 600 seconds, and it still crashes, so I guess it's not even paginating the products and returning all.

Is there a way to solve this? maybe like overriding the collection return, thanks!

enter image description here

2 Answers 2

2

Try clearing the data in the table ui_bookmark. Delete all the row in this table and execute some basic commands and check the Product page.

Deleting the ui_bookmark removes the filter/pagination already applied to the grids in the Admin panel so the default filter and pagination will be applied.

Default filter will be having 20 products only in the collection count.

4
  • is it safe to delete rows in that table? Mar 1, 2022 at 15:24
  • Yes, as I mentioned, it won't delete any data in the Database, but the filters applied to the Admin grids. For safe you can delete only the 'product_listing' namespace rows.
    – Sathya
    Mar 2, 2022 at 9:21
  • I have deleted the rows related to the admin user I'm using, it loads now products page, but still super slow, and sometimes it crashes if you try to go to the next page. Anyway, I will give you the point. Mar 2, 2022 at 14:55
  • Thanks for feedback, in that case you can check with the php memory_limit & execution time once.
    – Sathya
    Mar 3, 2022 at 4:56
0

Can you check your var/log files, most probable in system.log, but check the others as well, for an error similar to this one: Session size of xxxxx exceeded allowed session max size of xxxxx. [] []

If yes, then it is because the admin session size is too small for the amount of data that is being loaded by the admin grid. To increase it follow the steps from the DevDocs: https://docs.magento.com/user-guide/stores/security-session-management.html

We had the same issue for a custom module which would load a lot of API logs, so we can check if there are any issues. For us, we have raised it to 512kb, since it was trying to allocate almost 400kb. I would not set it to 0, which would disable it, to avoid any extremely high memory consumption. Just give it more than what it is trying to allocate, a safe margin, and continue monitoring for any issues in the future

1
  • I couldn't find any log related to that, I found some logs related to Redis locking Mar 2, 2022 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.