0

I'm running into a problem of Redis cache getting full, then when the client tries to Flush Cache through Magento Admin, it returns an error and signs out. It's necessary to always clean it through the command line.

Is there a way to prevent Redis from getting full? Or some easy interface to clean it?

1 Answer 1

0

You are facing the issue due to your Redis cache memory getting full. Once it's reaching the (maxmemory) parameter it's failing to store more hence the issue is coming.

  1. You need to increase the max memory limit to 10GB or more i.e. maxmemory_human:10.00G.

  2. Set up a cron to flush the Redis cache every night to keep the Redis-DB clean.

I had faced the same scenario and I have increased the max memory parameter to 10G and set the corn to clean the Redis cache every night at 2 AM. Now my issue had got fixed and I am not facing the issue again.

Hope this will help!

2
  • Hi Ubed, thank you for your time. Should I set these limits through the env.php file or directly on the server? Nov 30, 2021 at 14:48
  • You can set the limits directly on the server. Nov 30, 2021 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.