0

I have installed magento 2.4.2 community edition as multistore. The configurable products are uploaded with a csv from the supplier. On the page with all products I get the right message that the products are in stock or not, but on the productpage every items is 0 stock. I can put it in the shoppingcart with backorders disabled. Something messed up in my sources and stocks.

Now I use only the default stock, I have tried to move the stock to another source and back. Installed magento 2.4.2 and mageplaza advanced again. I checked all the settings from magento and mageplaza business advanced. When I change the stock in default, it only changes the salable stock. https://prntscr.com/11qkn0e

What do I have to change to show the stock with the right numbers?

0

From what I got to know about this issue, this seems to be a bug in M2.4.2 documented in https://github.com/magento/inventory/issues/3276. The issue itself is still open and there is no quality patch provided just yet in the official repository.

If you read the thread on the github open issue you will see that some suggest disabling the Magento_InventoryConfigurableProductFrontendUi module or use the the replace mechanism to omit this at composer level:

  1. cli: bin/magento module:disable Magento_InventoryConfigurableProductFrontendUi
  2. composer:
"replace": {
    "magento/module-inventory-configurable-product-frontend-ui": "*"
}

There are also other alternatives suggested there, but you will have to see which one suits your needs best.

Good luck!

4
  • Thank you, I found a workaround to get the 0 away. – Cisca Apr 21 at 8:53
  • no problem. did you find it in the link provided above? – Diana Botean Apr 21 at 8:55
  • Yes, I used the option to hide the 0 stock. I hope it will be solved in the next release. – Cisca Apr 21 at 13:44
  • roger that. then please consider marking/ accepting the answer i gave as solution so others can see it too. cheers and good luck! – Diana Botean Apr 21 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.