1

I'm unable to create catalog price rule and existing price rule too is not working in site. In console, I could see below error.

uncaught TypeError: Cannot read property 'select' of undefined at g.bindFieldsChange (grid.min.js:20) at g.initGrid (grid.min.js:7) at g.initialize (grid.min.js:3) at new g (legacy-build.min.js:1) at (index):160 at Object.execCb (39daca1563231596c195ad22ae44a0ec.min.js:112) at Module.check (39daca1563231596c195ad22ae44a0ec.min.js:56) at Module. (39daca1563231596c195ad22ae44a0ec.min.js:72) at 39daca1563231596c195ad22ae44a0ec.min.js:11 at 39daca1563231596c195ad22ae44a0ec.min.js:74

  1. I tried redeploying, as it seems to be js issue.
  2. I ensure no duplicate catalog rules in DB

Can some help me to identify issue and suggest for fix?.

0

When I tried to run php bin/magento indexer:reindex catalogrule_product command, I got below exception and fixed issue by removing duplicate entries and re running indexer command. Hope it helps someone

report.CRITICAL: Item (Magento\CatalogRule\Model\Rule\Interceptor) with the same ID "9" already exists.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.