0
a:4:{i:0;s:55:"Module "Mage_Newsletter" requires module "Mage_Widget".";i:1;s:758:"#0 /home2/ulashlvw/public_html/app/code/core/Mage/Core/Model/Config.php(851): Mage::throwException('Module "Mage_Ne...')
#1 /home2/ulashlvw/public_html/app/code/core/Mage/Core/Model/Config.php(815): Mage_Core_Model_Config->_sortModuleDepends(Array)
#2 /home2/ulashlvw/public_html/app/code/core/Mage/Core/Model/Config.php(318): Mage_Core_Model_Config->_loadDeclaredModules()
#3 /home2/ulashlvw/public_html/app/code/core/Mage/Core/Model/App.php(425): Mage_Core_Model_Config->loadModules()
#4 /home2/ulashlvw/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Model_App->_initModules()
#5 /home2/ulashlvw/public_html/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#6 /home2/ulashlvw/public_html/index.php(83): Mage::run('', 'store')
#7 {main}";s:3:"url";s:1:"/";s:11:"script_name";s:10:"/index.php";}
0

Magento 1 modules are handled inside the app/etc/modules/ folder of your website. Make sure that both Mage_Newsletter and Mage_Widget is set to active. It is most likely that Mage_Widget is disabled.

Inside app/etc/modules/Mage_All.xml :

      <Mage_Newsletter>
        <active>true</active>
        <codePool>core</codePool>
        <depends>
            <Mage_Core/>
            <Mage_Customer/>
            <Mage_Eav/>
            <Mage_Widget/>
       </depends>
    </Mage_Newsletter>`

Inside app/etc/modules/Mage_Widget.xml:

     <Mage_Widget>
        <active>true</active>
        <codePool>core</codePool>
        <depends>
            <Mage_Cms />
        </depends>
    </Mage_Widget>`

Clear cache afterwards : rm -rf filelocation/var/cache/*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.