0

Installed Smile-sa elasticSuite for Magento 2.3.3 and when indexing it gives this error:

Catalog Search indexer process unknown error:
Notice: Undefined index: type_id in /srv/html/src/vendor/smile/elasticsuite/src/module-elasticsuite-catalog/Model/Product/Indexer/Fulltext/Datasource/PriceData.php on line 64

Debugging that line 64 with a var_dump, i see that the dump looks like this:

    [18458]=>
  array(7) {
    [74]=>
    string(7) "1234566"
    [92]=>
    string(3) "N/A"
    [96]=>
    string(7) "Enabled"
    [122]=>
    string(13) "Taxable Goods"
    [71]=>
    string(4) "test"
    [72]=>
    string(4) "test"
    [73]=>
    string(4) "test"
  }

Now, this is happening on a dev site as a replica of the live site (same data) and with all extensions and themes REMOVED.

Trying the same on a fresh magento install i get this dump:

[1996]=>
  array(9) {
    ["entity_id"]=>
    string(4) "1996"
    ["attribute_set_id"]=>
    string(2) "10"
    ["type_id"]=>
    string(12) "configurable"
    ["sku"]=>
    string(5) "WSH06"
    ["has_options"]=>
    bool(true)
    ["required_options"]=>
    bool(false)
    ["created_at"]=>
    string(19) "2020-04-16 11:36:46"
    ["updated_at"]=>
    string(19) "2020-04-16 11:36:46"
    ["visibility"]=>
    string(1) "4"
  }

Which is correct, and indeed smile-sa ElasticSuite looks for that type_id key, which is missing from the live server data dump.

What could cause this issue on live server?

Do you have any suggestions on what might be the solution here?

Thanks!

1

This was solved.

After installation, somehow the catalog/search/engine was set to mysql instead of elasticsuite.

Changing that to the right value solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.