0

I get the 503 Backend fetch failed error when I try to connect to my Magento backend that is hosted on a AWS Lightsail Instance - 2 GB RAM, 1 vCPU, 60 GB SSD. I found the general tutorial on how to fix it https://devdocs.magento.com/guides/v2.3/config-guide/varnish/tshoot-varnish-503.html, but the path described there does not exist on my instance.

However, I found another tutorial https://community.bitnami.com/t/error-503-backend-fetch-failed-megenta-after-installation-extension/59593 that states it would also work to take the path /opt/bitnami/varnish/scripts/ctl.sh (that applied to my configuration), open the file and add to the VARNISH_OPTIONS parameter string i.e. "-p http_resp_hdr_len=65536". Still, I get the 503 Backend fetch failed error. This seems to be a common problem, I would appreciate any help with it!

I cannot even SSH into my console as the connectivity is so weak (or lost) that I cannot run the bitnami support tool.

2
  • Can you paste your vhost settings and varnish sertings
    – BartZalas
    Feb 21 '20 at 19:34
  • Also what is status of your cache, after reboot try to SSH and check with c:status
    – BartZalas
    Feb 21 '20 at 19:48
0

restart varnish service and list loaded parameters:

varnishadm param.show | grep http_

if its not there, try to load it directly:

varnishadm param.set http_resp_hdr_len 65536

you maybe out of RAM , as 2Gb is way too small.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.