0

I have installed the CoinGage_Merchant module in Magento 2.3 setup but when I fire di:compile command it is showing below error. I set the generated folder permission 777 before compile command but still, it is giving an error.

Class CoinGate\Merchant does not exist
Class CoinGate\Merchant\Model\Payment\Interceptor generation error: The requested class did not generate properly, because the 'generated'
directory permission is read-only. If --- after running the 'bin/magento setup:di:compile' CLI command when the 'generated' directory permission is set to write --- the requested class did not generate properly, then you must add the generated class object to the signature of the related construct method, only.

Does anyone has any idea, please share.

How to solve this issue?

1

Please run below commands to fix this issue

composer require coingate/coingate-php
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento cache:clean
php bin/magento cache:flush

Hope this will help you!

|improve this answer|||||
  • Thanks for your help but will it affect any other folder or file? – Utsav Gupta Nov 20 '19 at 7:22
  • No this will not affect any other files but it will download require lib for your extension. – Kishan Savaliya Nov 20 '19 at 7:22
  • Showing error as below: A typo in the package name - The package is not available in a stable-enough version according to your minimum-stability setting see <getcomposer.org/doc/04-schema.md#minimum-stability> for more details. – Utsav Gupta Nov 20 '19 at 7:48
  • What is your PHP and Magento version ? Can you please let me know that ? – Kishan Savaliya Nov 20 '19 at 8:57
  • PHP 7.1.33 and Magento 2.3.3 – Utsav Gupta Nov 20 '19 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.