0

I have written a custom html script which is saved in a custom block and displayed on a product page, which is a GET request and fetches the data from a node service on another service,

when the request is sent , Magento is adding a Number which im not sure why is it adding, it is not the cache version or the SID(&_=1567760378803).

https://test.test.eu/api/getProducts?&type=101&height=5&unit=1002&breadth=3&length=10&_=156776037880....

0

If you're not running a multi-website or multi-store environment, it's safe to disable the SID on the frontend.

To disable SID from the storefront go to:

  1. Magento dashboard > Store > Configuration > General > Web > Session Validation Settings > Use SID on Storefrontand set its value to No.
  2. Re-index Magento
  3. Refresh Magento cache

For more detail please visit This Link

0

Go to the Store > Configuration > General > Web > Session Validation Settings > Use SID on Storefront and set its value to No

enter image description here

After that run command (ssh)

php bin/magento cache:clean
php bin/magento cache:flush
php bin/magento indexer:reindex

The SID is a "session ID". Magento uses this to track a user's activity within the same Magento installation. Normally, Magento powers one website and one store from one installation (database).

Magento could power multiple websites with multiple stores from one installation though. The SID allows users to stay logged in while navigating across these websites/stores.

I think if you have the function enabled, the SID is sent when accessing catalog URLs so Magento can update the session with the user's location/state for the current website/store.

If you're not running a multi-website or multi-store environment, it's safe to disable the SID on the frontend.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.