Backorder is not working on Magento 2.3. How it works?

enter image description here


2 Answers 2


My team ran into this issue on a Magento v2.3.1 build and had to enable MSI to get things working. Once you've done this, make sure that you are able to set a negative Out-of-stock Threshold.

Though it isn't explicit in Magento's Documentation, and might actually be a current bug, if you're on v2.3.x of Magento, you'll need to enable MSI for Backorders to function properly. You can read read more about MSI and how to enable it here

UPDATE: it is a bug The fix for the bug is in this commit here, and will likely be merged into the next version of 2.3. If you're on Commerce or Commerce Cloud, you should be able to reach out to support for a patch. With this fix, you will not need to enable MSI.


Please check after Clear cache and Reindex

if still not working then

Can You please check Back-order Settings on individual product Edit tag on admin

Click on 'Advanced Inventory' Below Quantity field.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.