0

I am trying to select a few allowed shipping methods under UPS in the Magento 2 Admin.

I tried selecting the ones I want (e.g. UPS Standard, UPS Three-Day Select, UPS Next Day Air, etc) by holding the CTRL button and clicking each one. The ones I want change blue, and then when I click away they turn grey like they are supposed to. But when I click Save Config, it reverts back to selecting all the UPS Allowed Methods.

How can I fix this?

  • Is there anything in the console or logs? Have you tried a different combination of methods? – tjjen Aug 20 '19 at 19:56
  • can you advise on version of magento so this can be recreated thanks – Dava Gordon Aug 20 '19 at 20:59
  • 1
    Have you checked that the store view isn't overwriting this setting with system value? – maurisource web Aug 20 '19 at 21:40
  • There is nothing in the console or logs. I've tried selecting just one, and multiple ones and none of the options save. Other settings save, but not the allowed methods. The version is 2.3.1. The System value check box is not marked – Josiah Aug 22 '19 at 14:16
0

The default system value was overwriting the store view and would not change in the store view Default Config. I had to change the store view to My Store and then select the Allowed Methods that I wanted to use for UPS

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.