0

I have Magento 2.3.1. I am facing below error when I run command setup:di:compile.

Fatal error: strict_types declaration must be the very first statement in the script in vendor/magento/module-quote/Model/ChangeQuoteControl.php on line 8

1

src/Framework/Error/Deprecated.php

<?php declare(strict_types=1);
<?php
/*
 * This file is part of PHPUnit.
 *

src/Framework/Error/Error.php

<?php declare(strict_types=1);
<?php
/*
 * This file is part of PHPUnit.
 *

src/Framework/Error/Notice.php

<?php declare(strict_types=1);
<?php
/*
 * This file is part of PHPUnit.
 *

src/Framework/Error/Warning.php

<?php declare(strict_types=1);
<?php
/*
 * This file is part of PHPUnit.
 *

For more details refer: https://github.com/sebastianbergmann/phpunit/issues/2791

https://github.com/sebastianbergmann/phpunit/commit/70ccf0370f0b99c22819d3730167a7d448911b9e

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.