0

Please Help me on this, I have migrate data from magento 1.9.2.4 to 2.3.1 There is a error like this :-

Notice: Undefined offset: 19 in C:\xampp\htdocs\magento\vendor\magento\data-
migration-tool\src\Migration\Step\Eav\Data 279

  • Please Provide Full data about this, Error. ?? – Magento_Bhurio Apr 15 at 6:10
  • Notice: Undefined offset: 19 in C:\xampp\htdocs\magento\vendor\magento\data-migration-tool\src\Migration\Step\Eav\Data 279 – terms999 Apr 15 at 6:14
  • Please follow all steps while migration, check my ans on here for all steps: magento.stackexchange.com/questions/240255/… – Aasim Goriya Apr 15 at 6:21
  • Thank you. I have followed the exact steps. Initially I got two errors (1) max_allowed_packet changed to 100M and (2) integrity constraint, hence used --auto option. Now above error occurred. It occurs when data migration has restarted. 2nd time onwards, – terms999 Apr 15 at 6:31
0

Step For Data Migration :-

Install Data Migration Tool

1) Check your Magento 2 version :- sudo php bin/magento --version

2) Install Data Migration Tool from repo.magento.com :-

composer config repositories.magento composer https://repo.magento.com                                   
composer require magento/data-migration-tool:<magento_version>

3) Configure Magento 2 Data Migration Tool :-

    1 The above file will contain configuration and scripts for migrating from Magento 1 Open Source platform to Magento 2 Open          Source platform.
         <your Magento 2 install dir>/vendor/magento/data-migration-tool/etc/opensource-to-opensource

    2 The above file will contain configuration and scripts for migrating from Magento 1 Open Source platform to Magento 2 Commerce.
         <your Magento 2 install dir>/vendor/magento/data-migration-tool/etc/opensource-to-commerce

    3 The above file will contain configuration and scripts for migrating from Magento 1 Commerce to Magento 2 Commerce.
         <your Magento 2 install dir>/vendor/magento/data-migration-tool/etc/commerce-to-commerce

4) Configuring the migration :-

    1 Change to the following directory :-
      <your Magento 2 install dir>/vendor/magento/data-migration-tool/etc/<migration edition>/<ce or version>

    2 Rename config.xml.dist to config.xml 
      cp config.xml.dist config.xml

    3 Open config.xml in a text editor.

    4 Specify the following at minimum:

            <database host="localhost" name="Magento1-DB-name" user="DB-username" password="DB-password"/>

            </source>

            <destination>

            <database host="localhost" name="Magento2-DB-name" user="DB-username" password="DB-password"/>

            </destination>

            <options>

            <crypt_key>Magento1-Encrypted-Key</crypt_key>

            </options>

5) Migrate settings :-

        php bin/magento migrate:settings --reset vendor/magento/data-migration-tool/etc/<edition-to-edition>/<version>/config.xml

6) Migrate Data :-

        php bin/magento migrate:data --reset vendor/magento/data-migration-tool/etc/<edition-to-edition>/<version>/config.xml

        php bin/magento migrate:data --auto vendor/magento/data-migration-tool/etc/<edition-to-edition>/<version>/config.xml

7) Migrate Delta :-

        php bin/magento migrate:delta --reset vendor/magento/data-migration-tool/etc/<edition-to-edition>/<version>/config.xml

        php bin/magento migrate:delta --auto vendor/magento/data-migration-tool/etc/<edition-to-edition>/<version>/config.xml
  • Hello I have followed above suggested procedures. – terms999 Apr 15 at 6:48
  • any error generate ?? – Rk Rathod Apr 15 at 6:54
  • Hello I have followed above suggested procedures. (1)Migrate:settings is successful; (2)Migrate:Data is failed with "integrity checked failed error, data.php line 97" (3) Migrate:Delta is failed with error "In Pdo.php line 228: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'magento.sequence_rma_item_0' doesn't exist" – terms999 Apr 15 at 7:03
  • in data migration tool did not migrate custom table so try to remove that table or custom column – Rk Rathod Apr 15 at 7:31
  • in map.xml file you can ignore your table like this :- <ignore> <document>custom_table_name</document> </ignore> – Rk Rathod Apr 15 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.