0

I want to change all instances where the "phone number" field is listed to instead be labeled "Mobile Phone number" . I edited the file app/design/frontend/Smartwave/porto/Magento_Customer/templates/widgets/telephone.phtml recompiled and redeployed however I still see the text input labeled Phone number instead of mobile phone Number ??

Where else do I need to edit this so in the frontend and backend the field is labeled as I need it to be.

1

You have to change phone number instead Mobile Phone number then need to change below two file.

1) Below CSV will translate Phone Number text in frontend address.

File path: magento/app/design/frontend/Vendor/Theme/i18n/en_US.csv

"Phone Number","Mobile Phone number"

2) customer_address_form.xml helps to translate Phone Number text in admin address.

File path: magento/vendor/magento/module-customer/view/adminhtml/ui_component/customer_address_form.xml

Change <label translate="true">Phone number</label> to <label translate="true">Mobile Phone number</label>

<field name="telephone" sortOrder="130" formElement="input">
    <settings>
        <dataType>text</dataType>
        <visible>true</visible>
        <label translate="true">Mobile Phone number</label>
    </settings>
</field>

Run command and check.

cmd: php bin/magento cache:flush

Hope it help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.