3

I face issue when migrate from Magento 1 to Magento 2.3

Incompatibility in data. Source document: eav_attribute_group. Field: attribute_group_name. Error: The product attribute set "Testing" does not contain all required attribute group names "General, Prices, Design, Images"

Note : I created Testing Attribute set and add above 4 attribute group names in that attribute set. Still, it's not solve.

How to solve this issue?

  • Did you get any solution ? – Pawan Dec 13 '18 at 17:12
1

Yesterday I got the same issue and to fix above issue you need to edit Attribute Set Testing and add missing attribute group names. i.e General, Prices, Design, Images

If you edit Attribute Set Testing, you will find required attribute group name is missing.

Please make sure you attribute set having required attribute group names.

Just create empty group name and it will work!

Hope above will help!

  • I created Testing attribute set and add attribute group name in that set. But, still it's not solve. Can you please help me? – Emipro Technologies Pvt. Ltd. Feb 13 at 5:45
  • after changes error changed Or Same ? – Pawan Feb 13 at 16:23
  • Yes. same error. – Emipro Technologies Pvt. Ltd. Feb 14 at 4:18
  • try bin/magento migrate:data --reset, after adding above attribute set and group.-reset should work – Pawan Feb 16 at 2:11
  • Not working.... – Emipro Technologies Pvt. Ltd. Feb 16 at 6:46
0

It is due to you have rename default attribute group (General, Prices, Design, Images) to something else in your magento 1 website.

Or in your magento1 (General, Prices, Design, Images) where renamed. then you need revert its names back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.