1

The videoes on my products have stopped working. And I have found that it's froogaloop2.min.js being the problem. The trouble is, this is an external file and I have seen that it has been retired here and how to update it...

But the problem is, I don't know where I update this in magento. Would anyone be able to provide some guidance/a tutorial on how to do this? I just can't find any file that even calls the froogaloop file.

I am on Magento 2.2.0

5
  • the videos you are using as product videos are uploaded on vimeo ? Sep 11, 2018 at 6:14
  • Yes they are. A play icon appears over the image/thumbnail, when play is hit, it doesn't load. And it seems froogaloop is the problem.
    – jojo
    Sep 11, 2018 at 6:16
  • so that this js file is coming along with video code , because as you embed the video it calls the related iframe and show the video. did you check youtube ? to show videos Sep 11, 2018 at 6:18
  • I haven't checked youtube because I am wanting to use Vimeo for it. I can check youtube in a bit, just annoying having to setup API etc
    – jojo
    Sep 11, 2018 at 6:20
  • Youtube works fine. I checked the github for magento, it seems others are having the same problem
    – jojo
    Sep 11, 2018 at 6:48

1 Answer 1

0

I was able to get past that problem by simply replacing the reference to froogaloop2.min.js for this one... https://player.vimeo.com/api/player.js

1
  • how exactly do you replace the ref?
    – totneschap
    Oct 21, 2022 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.