1

I managed to move my magento store from my localhost to my live server, following this thread.

However, I have an unconventional folder structure how I run my main website and magento website. For instance,

This is the structure for my main website,

bin/
core/
local/
index.php

And I just want the magento system to be my sub 'website' as my webstore, so I keep all my magento files into bin/store/. And for this reason, all my images that I uploaded to wysiwyg/ don't work anymore - they are not displayed on screen anymore.

Also, the links with url rewrite are not working anymore too, for instance,

http://store.helloworld.com/wine/

I will get,

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator and inform them of the time the error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log. Apache Server at store.argenties.com Port 80

Any ideas how I can fix these two problems?

14
  • put your Magento installation in /bin/store and make your server look for /bin/store whenever it comes across http://subdomain.yourdomain.com/ Jun 11, 2014 at 15:37
  • I did set my server to look for /bin/store but still no good.
    – Run
    Jun 11, 2014 at 15:39
  • but are you able to go to your Magento store? Does it give you that 500 error right away? Jun 11, 2014 at 15:42
  • no 500 error. I can see the index page of my magento store. but i get the error in my question above when I click on the link on this index page, for instance the link to store.helloworld.com/wine
    – Run
    Jun 11, 2014 at 15:45
  • 1
    well, I'm out of ideas for today Sir, I'll come back and check tomorrow, hope someone comes across your question and has the answer Jun 11, 2014 at 16:07

1 Answer 1

1

The images may have the path of your localhost. Please check in code view in wysiwyg editor what path your images have.

The Internal Server Error may be related to a wrong/incompatible setting in the .htaccess. Did you change anything there?

3
  • It is the problem from the live server actually. AVOID godaddy at any cost!
    – Run
    Jun 20, 2014 at 13:20
  • 1
    So did you switch the hoster and now it's working? general note here: most of the shared hosters will have problems with Magento (performance, special settings)
    – jonazu
    Jun 23, 2014 at 8:54
  • Yes it runs fast on siteground hosting.
    – Run
    Jun 23, 2014 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.