I have made required 'Show Prefix' from admin config setting. Now prefix is shown on the customer account edit page.

But, when i am trying to save customer prefix, then i am getting Error: "Name Prefix" is a required value." enter image description here

I have also used 'Prefix Dropdown Options' but again, I am getting same error.

enter image description here enter image description here I am getting this error in Magento Ver 2.2.1, Ver 2.2.2 and Ver 2.2.3. Is anybody else getting this type error?

4 Answers 4


This is a Magento bug.

Please check this issue at magento issue list: https://github.com/magento/magento2/issues/7499

Might at this another issue, they have the fix issue


The fix will be available with the upcoming patch release.


This is not a error, its just validating the form data, if you dont want prefix as a required field, then you can change to OPTIONAL from the magento admin customer configuration settings.

Steps: MagentoAdmin->Stores->Configuration->Customer->CustomerConfiguration->Name and Address Options->Show Prefix->Optional


In my case, the reason was a missed value in the table customer_form_attribute.

Check if all form codes are maped to prefix attribute:


Probably missed adminhtml_customer form code is a cause of the issue.


You just need this:

Go to: Configuration -> Customers tab -> Customer Configuration -> Name and Address Options section -> Show Prefix -> No

Clean the cache, and you will get removal of Name Prefix option from frontend.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.