0

I created a copy of a project and of the database. Everything seems to work fine by far, but some pages are not working and I get to see the "sorry, page not found" site. No product site is working actually.

Let's take a look at the database table core_url_rewrite:

enter image description here

it looks fine. But if I go to https://www.mysite.de/produkte/klebstoffe.html then I get the Sorry page not found site.

If I enter the whole url "https://www.mysite.de/catalog/category/view/id/74" then I get redirected to a page, but to another page then I get on the original project which I have cloned.

Steps for reproduction

  1. Create a copy of the original project e.g. `cp -R original_shop/ copy_shop/

  2. Create dump of original_shop database

  3. Create a new database for copy_shop

  4. Import database dump from original_shop to copy_shop

  5. Change web/unsecure/base_url and web/secure/base_url to point at the domain of copy_shop.

  6. Change app/etc/local.xml to point to the new database.

  7. Clear cache and /var folder.

  8. Reindex everything

  9. Try to view a product. You will most likely get to see the page "sorry page not found"


What I have tried

  • Truncating the table core_url_rewrite and reindexing the whole site.

Result: No change.


Reindex all

I reindexed everything by using n98-magerun

./n98-magerun.phar index:reindex:all
Started reindex of: catalog_product_attribute
Successfully reindexed catalog_product_attribute (Runtime: 1s)
Started reindex of: catalog_product_price
Estimated end: 2018-06-14 12:27:29 UTC
Successfully reindexed catalog_product_price (Runtime: 4s)
Started reindex of: catalog_url
Estimated end: 2018-06-14 12:27:32 UTC
Successfully reindexed catalog_url (Runtime: 4s)
Started reindex of: catalog_product_flat
Estimated end: 2018-06-14 12:27:36 UTC
Successfully reindexed catalog_product_flat (Runtime: 3s)
Started reindex of: catalog_category_flat
Successfully reindexed catalog_category_flat (Runtime: 0)
Started reindex of: catalog_category_product
Successfully reindexed catalog_category_product (Runtime: 1s)
Started reindex of: catalogsearch_fulltext
Estimated end: 2018-06-14 12:27:38 UTC
Successfully reindexed catalogsearch_fulltext (Runtime: 1s)
Started reindex of: cataloginventory_stock
Successfully reindexed cataloginventory_stock (Runtime: 0)
Started reindex of: tag_summary
Successfully reindexed tag_summary (Runtime: 0)

Result: No change.


What is going on?

  • You can also try to check .htaccess file and Your local apache settings. – Konrad Siamro Jun 14 '18 at 10:30
  • Ah another question. What about categories? Do you have few root categories? Lets check magento.stackexchange.com/questions/156753/… – Konrad Siamro Jun 14 '18 at 10:30
  • @KonradSiamro, I don't use .htaccess, we are using nginx without apache. – Black Jun 14 '18 at 11:59
  • @KonradSiamro, Yes there are categories, the same as in the original project which I have copied. – Black Jun 14 '18 at 12:03
  • does it work for https://www.mysite.de/index.php/produkte/klebstoffe.html ? – Marius Jun 14 '18 at 12:22
0

I found the answer. It happened because I ommited some big tables while exporting, which were necessary for the products to work, e.g.

enter image description here

I did not mentioned it in the question. Totaly my fault.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.