0

On Magento 1.9, I need to add the field prefix to the shipping_address and billing_address nodes in the response of salesOrderInfo (soap-api-v2). I tried by adding the following:

app/code/core/Mage/Sales/etc/wsi.xml:

<xsd:element name="prefix" type="xsd:string" minOccurs="0" /> (line 275)

app/code/core/Mage/Sales/etc/wsdl.xml:

<element name="prefix" type="xsd:string" minOccurs="0" /> (line 274)

The prefix field contains a value (I can verify it with debug breakpoints in Mage_Sales_Model_Order_Api::info()) However, the SOAP response still does not contain the field. I even tried to set a ini_set("soap.wsdl_cache_enabled", 0); in the index.php to disable the wsdl cache, flushed the regular cache, restarted the Apache server, but with no success.

Does anybody have an idea how to make this work?

0

I finally found an answer. I just restarted the computer with the changes listed above and the response contained the field prefix. I have no idea which cache was involved (I had flushed them all), apparently one was still returning the old field structure.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.