1

Can anyone help me how to resolve the below problem.

after di:compile command my site is blank in windows xampp server.

Thanks

1

aftre di compile use this command

php bin/magento setup:static-content:deploy -f
rm -rf var/generation var/cache var/page_cache var/view_preprocessed
php bin/magento indexer:reindex
php bin/magento cache:clean
php bin/magento cache:flush
  • i was running windows 10 and i used to see blank screen after di:compile. I tried on ubuntu 16.04 LTS and it worked. – Guru May 5 '18 at 17:09
1

Please go to app\bootstrap.php

error_reporting(E_ALL);

#ini_set('display_errors', 1);

and also check log files under var/log or var/report folders

or else you can first do these,

First delete below folders : go to root directory

pub\static

var\cache

var\page_cache

var\view_preprocessed

var\generation

And run below commands

php bin/magento setup:static-content:deploy

php bin/magento indexer:reindex

1

This can be caused by any error. Please enable the error reporting by editing your bootstrap.php file located at following path:

magento_root/app/bootstrap.php

error_reporting(E_ALL);
ini_set('display_errors', 1);

Check the deployment mode and switch it to developer to get more information about the error. Check the logs and reports found at following path:

magento_root/var/log

magento_root/var/report

If the issue persist, try clearing following directories:

magento_root/pub/static

magento_root/var/cache

magento_root/var/page_cache

magento_root/var/view_preprocessed

magento_root/generated

And run following commands from console:

php bin/magento setup:static-content:deploy -f

php bin/magento indexer:reindex

php bin/magento cache:flush

1
 1. php bin/magento setup:static-content:deploy -f
 2. php bin/magento indexer:reindex
 3. php bin/magento cache:flush

and did not got my home page after trying all the above , then i tried one more command

- php bin/magento setup:upgrade
 - php bin/magento cache:flush

and then I can see my home page.

0

It is Worked for me after remove global.php file under magento root /genereted/metadata/

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.